Bienvenue sur le portail développeur Forums Plateforme user/mdp après installation sur rpi3

Mots-clés : 

8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #5610

    ACD
    Participant

    Bonjour,

    J’ai fait l’installation server sur un rpi 3 sous strech En utilisant l’url pour se connecter, quel user et mot de passe faut-il utiliser?
    merci pour les infos,

    #5611

    marmoul70
    Participant

    Bonjour,
    Il faut que tu utilises les user mdp que tu te sers pour te connecter au forum constellation.

    #5612

    ACD
    Participant

    Bonsoir,

    Cela ne fonctionne pas mais peut-être parce j’ai un @ dans le mdp.
    En redemandant un nouveau mot de passe, j’ai le message : Votre lien de réinitialisation de mot de passe semble être invalide. Veuillez demander un nouveau lien ci-dessous.

    Si vous avez une piste

    merci

    #5613

    marmoul70
    Participant

    C’est bizarre car Sébastien a remis à jour la lib Linux ( enfin j’ai pas encore essayé personnellement) mais apparemment sa ne marche pas pour toi.
    Peut être qu’il aura des réponses à t’apporter car sa dépasse mes compétences 🙂

    #5615

    Sebastien Warin
    Admin bbPress

    Hum, étrange en effet, je pensais avoir résolu les problemes d’encodage des mdp sur l’installeur Linux.

    Je vais refaire des test avec des @ dans le mdp.

    @acd : tu as pu renouveler ton mdp, ou tu veux que je le fasse ?

    #5624

    ACD
    Participant

    je viens de la faire et c’est ok pour le changement de mot de passe (avec % comme caractère spécial). Par contre, cela ne fonctionne pas pour me loger sur le rpi.
    mais comment le rpi peut connaitre le nouveau mot de passe alors que je suis sur mon réseau local ?
    merci,

    #5628

    Sebastien Warin
    Admin bbPress

    Hello,

    Hum donc c’est bien le @ qui posait problème ?

    Sur le RPi, si tu évoques la page de login Constellaiton Console, il s’agit des credentials défini durant le setup de ta Constellation !

    En effet, pour les setups (WPI) Linux et Windows, il faut s’identifier avec son compte créer sur le portail Constellation pour pouvoir installer les composants Constellation. Par contre pour le reste, c’est les credentials configurés dans la config du serveur dont deux clés sont configurées au setup.

    Quelques ressources pour bien comprendre :
    https://developer.myconstellation.io/concepts/securite-accesskey-credential-authorization/
    https://developer.myconstellation.io/constellation-platform/constellation-server/fichier-de-configuration/#Section_credentials
    https://developer.myconstellation.io/constellation-platform/constellation-console/gerer-credentials-avec-la-console-constellation/

    Si mot de passe admin perdu, soit on réinstalle tout via le WPI, option « Perform clean install », soit on change juste l’access key dans la config, pour cela :
    1/ trouver un nouveau couple login/password (ex: admin/password)
    2/ créer l’access key associée, c’est à dire le SHA(login+password), soit ici SHA1(« adminpassword ») = efacc4001e857f7eba4ae781c2932dedf843865e (http://www.sha1-online.com/)
    3/ éditer le ficher de configuration « Constellation.Server.exe.config » (dans /opt/constellation-server sur Linux ou C:\Program Files\Constellation Platform\Server sur Windows)
    4/ remplacer l’accesskey « Administrator » par la nouvelle clé (cf etape 2)
    5/ relancer le serveur Constellation (sudo supervisorctl restart constellation-server ou via la MMC Services dans Windows)

    #5636

    ACD
    Participant

    bonjour,

    J’ai tout réinstaller avec des mots de pass sans caractère spéciaux et c’est ok.
    Je vais avancer un peu avant de retester avec mdp et caractères spéciaux.

    merci,

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.